RAMMS CHANGELOG

V 1.6.20 [2014-03-05]

GENERAL

e Bugfix: “Install Update from local folder” did not work. Resolved.

e BugfTix: “AutoWebUpdate” would not have detected 64-bit processors, updated
software would have worked as 32-bit version. Resolved.

e BugfTix: Colortable-Nr of colorbar can be changed interactively. Did not work
before. With "Help - Advanced... - Color Tables... -2 View Color Tables®™ the
available colortables (with index number) can be viewed and with "Help >

Advanced... -2 Additional Preferences... 2 Edit" the colortable can be
changed (set COLORTABLENR to the corresponding index number, click Save and
0K) .

e Improvement: Memory management generally improved. E.g. before starting a

simulation, RAMMS closes the input file. RAMMS then uses less memory.

e Improvement: IDL version updated to 8.2.3.

e Improvement: New Time Plots and Line Profile Plots.

e Improvement: Summary of Moving Mass shows new plots and tables to analyse the
mass flow.

e Improvement: Automatic export of ASCII files after a simulation of: Max flow
height, max velocity, max pressure and deposition (last dump step).

e New Feature: Generation of ASCII files (max flow height, max velocity, max
pressure and deposition) from multiple output files.

e New Feature: Visualizations can now be deleted from view (file tree in the
left panel), Remove Visualization Button *.

e New Feature: Draw New Polygon Shapefile; normal polygon shapefiles can be
plotted (use this button 4 in the upper horizontal toolbar).

e New Feature: The velocity direction vector can now be plotted as an arrow

(use this button M in the left vertical toolbar). Arrows will change in size
and lengths when zooming into the visualization. The appearance of the arrow
can be changed in the “Additional Preferences” (ARROW_COLOR, ARROW_FACTOR,
ARROW_HEADSIZE, ARROW_LENGTHSCALE, ARROW_THICK) .

e New Feature: Improved numerical scheme. Small numerical instabilities in very
steep terrain are corrected with the improved numerical scheme. Mass loss is
minimized due to a lower Hcutoff. Default Hcutoff = 0.000001m.

e New Feature: Cohesion implemented. The basic Voellmy friction equation has
been modified to include cohesion. It increases the shear stress and
therefore causes the avalanche or debris flow to stop earlier, depending on
the value of the cohesion.

e New Feature: Obstacle/Dam feature implemented. Draw polygons of areas, where
no avalanche or debris flow should pass (houses, deflecting dams, obstacles).
The flow is deflected.

e New Feature: Curvature is taken into account in the frictional model. The
normal force N now includes centrifugal forces arising from the terrain
curvature. Typically this increases the friction, causing the flow to slow
down in tortuous and twisted flow paths.

e New Feature: RAMMS::Viewer available now! With the viewer, you can look at
your RAMMS simulations even if your license expired! You are not able to do
new simulations.

e New Feature: “GIS -2 Convert Polygon Shapefile.. 2 to RAMMS Domain Shapefile”.

e New Feature: Button “Colorbar Properties’ changed to “Additional
Preferences”.



e New Feature: Shapefile color can be changed in the “Additional Preferences’
(SHAPEFILE_COLOR) .

DEBRIS FLOW

e Improvement: Hydrograph improved: Capturing of improper input and numerical
implementation of hydrograph improved.

V 1.5.01 [2012-12-13]

GENERAL

e Bugfix: When changing the background color in the preferences, RAMMS did not
save this position. Fixed.

e BugfTix: The vertices of polygon shapefiles were written in both clockwise and
counter-clockwise order, depending on how the user clicked the points. ArcGIS
is having problems to work with counter-clockwise polygon shapefiles. Polygon
shapefiles are therefore written only in clockwise-order.

e BugfTix: “Help - Advanced.. = Hardware Rendering” did not work. Fixed.

e Bugfix: “Help -2 Advanced.. 2 Install C++ Libraries” did not work. Fixed.

e Improvement: When changing the background color to white, the axes of the
project region are still visible, and the text of the colorbar is also white.
The axes can be disabled and enabled (“Edit - Show Dataspace Axes’), and the
text-color of the colorbar can be switched between white and black (“Edit >
Colorbar White Color?).

V 1.5.0 [2012-11-27]

GENERAL

e Bugfix: Bug found in the license procedure. When a user entered a wrong
license key, the license was saved anyway, and RAMMS then could not be
started anymore. Resolved.

e BugfTix: Negative coordinates did not work anymore in version 1.4.14.
Resolved.

e Bugfix: Bug found in the MuXi-classification with a forest cover, if DEM
resolution was equal to 10m. RAMMS could not complete the classification and
showed an Error Message. Resolved.

e Bugfix: Bug resolved when converting a shapefile to a RAMMS release
shapefile.

e Bugfix: Bug found in the GIF-Animation procedure. Two GIF-Animations could
not be generated one after the other, because the first file was not closed.
Resolved.

e Bugfix: Until now, coordinates were saved as float-values. With high
resolution DEM’s, this could lead to a loss of accuracy (in the range of
0.1m). Coordinates are now saved as double values.

e Improvement: 64-bit Support! If you have a 64-bit computer (Windows 7),
please uninstall your current RAMMS version, download the new 64-bit version
from ramms.slf.ch and install it. Your old license key will still work with
the new 64-bit version. The 64-bit Version will solve many memory problems,
because more dynamic memory can be allocated.

e Improvement: Updated from IDL 7.1 to IDL 8.2.1.

e Improvement: The Map/Orthophoto procedure was improved. RAMMS now finds also
maps/orthophotos, that cover the project region only partially! RAMMS also
shows a percentage of coverage.

e Improvement: Zoom level resets to 100% when closing an input- or output-file.



Improvement: RAMMS issues a warning message, if the user tries to draw a
release area or a calculation domain in 3D-mode.

Improvement: Version 1.5 introduces a new RAMMS application user directory.
Prior to version 1.5, the application directory was located here:
“C:\Documents and Settings\<user name>\.rammsl.X.X” (Win XP) or
“C:\Users\<user name>\_.rammsl_X_.X> (Win 7)

For every new version of RAMMS, a new application directory was created, and
the old one was copied into the new one, occupying a lot of disk space.

The new application directory is created only once and is located here:
“C:\Documents and Settings\<user name>\.idIN\slIf\ramms” (Win XP) or
“C:\Users\<user name>\_idI\slf\ramms” (Win 7).

New Feature: Outflow-Volume-Alert — RAMMS alerts the user, if volume is
flowing out of the calculation domain.

New Feature: Annotation-Buttons in the horizontal toolbar can be deactivated
(and activated).

New Feature: New buttons were implemented in the horizontal toolbar (to the
right side) — MuXi-File, Slope Angle, Curvature, Contour, Max Flowheight, Max
Velocity, Max Pressure, Time Plot, Export ASCIl, Show Project Folder,
Add/Change Map/Orthophoto.
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New Feature: RAMMS About Box (“Help - About RAMMS”) shows whether you are
using the 32- or the 64-bit RAMMS version.

New Feature: Quasi 3D-Visualization of flow height implemented. The flow
height can be visualized exaggerated by a factor. This factor can be changed
in “Help > Advanced.. > Additional Preferences.. > Edit’, keyword
EXAGGERATION.

New Feature: Batch-Mode -> Possibility to start up to 50 simulations
automatically (e.g. over night). Users can choose, how many computational
cores the Batch-Mode should use (quasi parallel simulations, saves
computational time!). “Track - New.. > Run BATCH simulations’

New Feature: Import one (1) attribute from polygon shapefiles (e.g. release
depth) when converting them to a RAMMS release shapefile.

New Feature: Colorbar can be moved anywhere in the screen (Attention,
colorbar can get lost now! © ). Use “Project > Get Colorbar’ to find a lost
colorbar.

New Feature: Open Project Folder in Windows Explorer from within RAMMS. Use
the appropriate toolbar button OJ in the horizontal toolbar or “Project -
Open Project Folder (Windows Explorer)”.

New Feature: Polyline Shapefiles can be visualized in RAMMS.

New Feature: User can choose between the operating system’s native (hardware)
rendering system or a platform independent (software) rendering system for
IDL Object Graphics displays. Hardware rendering allows IDL to make use of 3D
graphics accelerators that support OpenGL, if any are installed in the
system. In general, such accelerators will provide better rendering
performance for many object graphics displays. This is typically true for
images rendered using texture-mapped polygons (typical for RAMMS). Anyway,
there are situations, where it can be better to use software rendering.
Hardware rendering can be switched off (and software rendering switched on)
by unchecking “Help - Advanced.. > Hardware Rendering’.

New Feature: Resetting General Preferences. Use “Help - Advanced.. > Reset
General Preferences” to reset the General Preferences.

New Feature: View Google Earth Map Projection Options with “Extras -> Google
Earth.. > Map Options Help~.




DEBRIS FLOW

e New Feature: Define Additional MuXi Areas > Users can add polygon regions
with different mu and xi values (Run - Run Calculation: Mu/Xi Tab). Be
careful in using this feature!

V 1.4.14 [2011-11-24]

GENERAL

e Bugfix: An error could happen when RAMMS tried to grid the simulation data.
This only happened with small grid resolutions. Resolved.

e Improvement: File tree improved in the right panel.

e New Feature: Reading DEM-files: RAMMS accepts “xllcenter/yllcenter’ keywords
in ASCII-grid files (until now, RAMMS only accepted “xllcorner/yllcorner”).

e New Feature: AutoWebUpdate. When you start RAMMS, it will automatically check
for updates on the internet. This could lead to an Error-Message, if your
firewall blocks the executable “idlrt.exe” (this file starts the IDL-Virtual
Machine you need to run RAMMS). Please unblock this file for your firewall.
You can also disable the AutoWebUpdate-Function by unchecking “Help -
Advanced.. > AutoWebUpdate’. The WebUpdate-Function can still be done
manually (“Help - Update.. > Web Update’ or “Get Update Manually (download to
local folder)”).

e New Feature: Logging. By default, RAMMS writes status messages in a log file.
You can access this file with “Track - Log Files.. > RAMMS Log File (current
session) or (last session)’. The “(last session)” log file can be useful in
case of a crash. You can disable the Logging-Function by unchecking “Help -
Advanced.. > Logging” (this could result in a slightly faster execution of
RAMMS, but only slightly).

AVALANCHE

e Bugfix: MuXi error: When the MuXi file was selected in the “Run Simulation’-
window (with the “Select MuXi File..” button, see picture below), instead of
selecting the MuXi Ffile with “Input > Friction Values.. > Load Existing MuXi
File’, the following happened:

0 the selected MuXi name was correctly displayed in the text field on
the left of the button

o0 the output log file showed the selected MuXi file

o BUT, RAMMS did not calculate with the selected MuXi File, but used
the “old”, previously selected MuXi file instead. If you frequently
used the button in the picture below, you should check your
simulations. Otherwise, you do not have to do anything.
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This bug is resolved! MuXi files can be selected with “Input - Friction
Values.. &> Load Existing MuXi File” or in the “Run Simulation’-window with
the button “Select MuXi File..” (see picture above).






V 1.4.10 [2011-09-07]

GENERAL

e Bugfix: An error occurred when trying to crop release areas and then cancel
the process instead of entering a new name. Resolved.

e Bugfix: Several button-tooltips did not work. Resolved.

e Improvement: When working with large TIFF files, the available memory is
checked, and a message appears, if not enough memory is available

e New Feature: New RAMMS Modules can be registered directly in RAMMS (“Help -
Register New RAMMS Module?).

AVALANCHE

e Bugfix: An error occurred when trying to re-calculate an old project with old
MuxXi Files (Shapefile-type). This error is resolved.

e Bugfix: An error occurred when trying to calculate a new MuXi file with a
grid resolution of 10m. This error is resolved.

e Improvement: Create New MuXi File: The Global Parameters Window is
automatically shown when creating a new MuXi file.

DEBRIS FLOW

e OFfFficial release of RAMMS: :Debris Flow Module
e Web page at http://ramms.slf.ch
e Email: ramms@slf.ch

V 1.4.07 [2011-08-09]

Cygwin/GRASS has been removed from the RAMMS software package. RAMMS does not
use Cygwin/GRASS anymore. Due to major problems on Windows 7 we decided to
remove Cygwin/GRASS. Therefore major changes were made in this RAMMS version,
see below.

e Installation: You can install RAMMS wherever you want now. “C:\Program
Files\RAMMS” is possible. BUT, “blancs” and “special characters’ are still
not allowed in project names and working directories.

e New Project: The creation of a new project is significantly faster without
Cygwin/GRASS!

e MuXi-Files: The automatic classification of mu and xi is more accurate and
MUCH FASTER now. Due to the improved classification procedure, the result of
a muxi-classification is not exactly the same as in the earlier version.
Fortunately, the differences are very small and therefore not significant for
simulation results.

e MuXi-Files: The muxi-values are saved as ASCII-files, and not as shapefiles
anymore. However, old muxi-shapefiles can still be imported, visualized and
simulated.

e MuXi-Files: MuXi-Values are only visualized within the calculation domain!

Some other new features and improvements:

e New Feature: File-Tree available in the right Avalanche panel. Release-,
MuXi-, Forest-, Calculation Domain- and Shapefile-Files within the project
directory are listed in the file-tree. Select any file and it will be
displayed immediately.

e New Feature: Run a simulation in the background. Simulations can be run in
the background, you can continue to prepare a new simulation and start more
simulations simultaneously.



e New Feature: Jump directly from a simulation to the corresponding input file.
A new button has been added to the vertical toolbar:

e New Feature: Zoom with mouse wheel.

e Improvement: Handling of maps and orthophotos is improved. RAMMS does not
crop maps/orthophotos anymore and you don’t have to save these cropped
maps/orthophotos all the time. RAMMS uses always the same original file for
the visualization.

e Improvement: Error handling improved. RAMMS should crash less. In case of an
error, RAMMS shows an Error-Windows, but RAMMS does not crash anymore. 1f you
experience a crash, please report the circumstances to ramms@slf.ch!

e BugfTix: It happened that the settings in the Global Parameters were not
accounted for correctly when calculating a MuXi-file. This bug is corrected.

e Bugfix: Some MuXi-values for Tiny-10year were missing in the Automatic MuXi
Procedure window. This bug is corrected.

V 1.3.16 [2010-11-11]

e New Feature: Drawing of lines and polygons (Line-Profile; Release-, Domain-
and Forest-Polygons) changed. Problems of closing the lines and polygons with
a double-click were reported. Lines and Polygons are to be closed now with a
RIGHT MOUSE CLICK.

e New Feature: Raster information available! Until now, the raster information
used in GRASS was available in the GIS/GRASS logfiles. To make it easier to
check whether FOREST and DEM raster information is available, this
information can be viewed in the "Project”-menu.

e New Feature: Colors of the Colorbar can be changed! With “"Help -> Advanced...
-> Color Tables... -> View Color Tables®™ the available Color Tables can be
viewed and with "Help -> Advanced... -> Additional Preferences... -> Edit"
the Color Table can be changed.

e New Feature: Map/Orthophoto-Selection-Window enlarged. The width of the
window can be set in the “Additional Preferences”.

e New Feature: RAMMS informs one week before expiration of the license. The
expiration date can be looked at in “Help -> About RAMMS®.

e Improvement: Grid resampling improved. Until now, every grid was resampled,
even if the calculation resolution matched the DEM resolution. Matching
resolutions are not resampled anymore. Simulations can now be performed on
exactly the input DEM!

e Improvement: Estimation of release volume improved. With matching calculation
/ DEM resolutions (see above) the estimation of the release volume is
improved significantly.

e Improvement: Conversion of Polygon Shapefiles to RAMMS Forest Shapefile
improved.

e Improvement: The routine to produce a GIF-Animation was improved. The delay
of the images within a GIF-Animation can be controlled by the parameter
"GIFANIM_DELAY_TIME®" in the "Additional Preferences”, see above. The value
represents the delay in hundredths (1/100) of a second.

e Bugfix: "Commas® as decimal points or changed order of header lines in ASCII
DEM files resulted in a program crash. This bug is resolved.

V 1.3.08 [2010-08-19]
e BugfTix: A small error was found when dealing with FORESTED areas below

"Altitude Limit 1" (in Switzerland below 1500 m.a.s.l.). It"s possible that
too high values of "mu® are used for the forested areas in the MuXi-Ffile.

V 1.3.05 [2010-03-23]



e Improvement: Improved memory management, RAMMS uses less memory now.

e Improvement: Colorbar handling improved. The colorbar changed size when
zooming. This was very annoying. Resolved. Font size and font type can be
changed now.

e Improvement: Export image feature improved: Only GIF and TIFF images could be
exported until now. New Ffile types: .bmp, -jpg, -pict, .jp2

e New Feature: 30-day Demo Version available. See http://ramms.slf.ch.

V 1.3.0 [2010-03-01]

e OffFficial release of RAMMS::Avalanche Module
e Web page at http://ramms.slf.ch
e Email: ramms@slf.ch




